[Tiago Motta] Gem brazilian-rails em versões de rails antigas

Se você estiver usando uma versão antiga do brazilian-rails é bem provável que ao tentar instalar esta gem ela comece a instalar também versões superiores do rails. Isso porque esta gem possui um conjunto de dependências definidas somente com o operador “>=”.

Ou seja, se você tentar instalar a versão 2.1.13 por exemplo, que funciona com o rails 2.3.2, ele tentará baixar a dependência da gem brdinheiro “>= 2.1.13″, acabando por baixar a versão 3.0.0, que depende do activerecord 3.0.0, do rails 3. Nem preciso dizer que isso acabará dando merda.

A solução é baixar todos os componentes independentemente sem suas dependências da seguinte forma:

sudo gem install brnumeros --version=2.1.13 --ignore-dependenciessudo gem install brdinheiro --version=2.1.13 --ignore-dependenciessudo gem install brcep --version=2.1.13 --ignore-dependenciessudo gem install brdata --version=2.1.13 --ignore-dependenciessudo gem install brhelper --version=2.1.13 --ignore-dependenciessudo gem install brstring --version=2.1.13 --ignore-dependenciessudo gem install brcpfcnpj --version=2.1.13 --ignore-dependenciessudo gem install brI18n --version=2.1.13 --ignore-dependenciessudo gem install brazilian-rails --version=2.1.13 --ignore-dependencies